Kronos Issues

Incident Report for St Vrain Valley Schools

Resolved

This incident has been resolved.
Posted Aug 22, 2025 - 11:57 MDT

Investigating

Some staff are experiencing issues when trying to log into Kronos. The vendor has identified the issue and is working to resolve it as quickly as possible.
Posted Aug 22, 2025 - 09:45 MDT
This incident affected: Other.