The issue has been resolved for the majority of affected phone lines. Lumen is continuing to work on restoring service to the remaining ten lines.
Posted Mar 13, 2026 - 07:25 MDT
Update
We continue to work with multiple vendors and have active support cases open on the issue impacting inbound calls to some District phone lines.
Posted Mar 12, 2026 - 07:12 MDT
Update
We continue to work with our vendors to resolve the phone issues that are impacting inbound calls to some District phone lines. Main school numbers and the ESC main number are not impacted.
Posted Mar 11, 2026 - 15:59 MDT
Identified
Latest update from Lumen - Technician is currently onsite working on the repair
Posted Mar 11, 2026 - 14:37 MDT
Investigating
We are currently investigating phone issues that are impacting inbound calls to some District phone lines. Main school numbers and the ESC main number are not impacted. We are working with Lumen to resolve this issue.
Posted Mar 11, 2026 - 11:50 MDT
This incident affects: Network and Phones (Landlines).