Service Alert – Investigating Issue with Securly Filter

Incident Report for St Vrain Valley Schools

Resolved

This incident has been resolved.
Posted May 19, 2026 - 11:26 MDT

Identified

The vendor had identified the issue and implemented a fix. DTS continues to monitor.
Posted May 19, 2026 - 09:08 MDT

Investigating

We are currently investigating an issue affecting Securly Filter. Teams are reviewing system performance and working to determine the scope and root cause. Additional updates will be provided as we learn more.
Posted May 19, 2026 - 07:30 MDT
This incident affected: Network and Phones (Securly).