Seesaw Issue

Incident Report for St Vrain Valley Schools

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 15:25 MDT

Investigating

Seesaw is currently experiencing an issue that prevents iPad users from launching Seesaw from the ClassLink Launchpad. Seesaw is aware of the issue and is working to resolve it as quickly as possible.
Posted Aug 15, 2025 - 14:07 MDT
This incident affected: Seesaw.