Securly Content Filtering Issue

Incident Report for St Vrain Valley Schools

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 11:04 MDT

Investigating

We have identified an issue with our content filtering provider, Securly. We are working with the vendor to resolve the issue as quickly as possible.
Posted Aug 21, 2025 - 10:10 MDT
This incident affected: Other.