Service Alert - Verizon Outage

Incident Report for St Vrain Valley Schools

Resolved

The issue affecting the Verizon Outage has been resolved. All systems are operating normally. If you continue to experience any problems, please email helpdesk@svvsd.org so we can assist.
Posted Feb 18, 2026 - 13:53 MST

Investigating

We are currently investigating an issue affecting calls due to a Verizon service disruption. Verizon wireless customers are receiving a busy tone when attempting to call district landline phones. All other cellular providers should not be affected. Our teams are reviewing system performance and working to determine the scope and root cause. Additional updates will be provided as we learn more.
Posted Feb 17, 2026 - 14:03 MST
This incident affected: Network and Phones (Landlines).