Service Alert – Investigating Issue with XtraMath

Incident Report for St Vrain Valley Schools

Resolved

This incident has been resolved.
Posted Dec 17, 2025 - 12:05 MST

Investigating

XtraMath is currently unavailable across the nation. DTS has reached out to the vendor for an update.
Posted Dec 17, 2025 - 10:52 MST
This incident affected: Other.